Monday.com Client Portal System Down
Incident Report for Polished Geek
Resolved
Our Polished Geek Monday.com client portal is back up and functioning normally.
Posted Jan 29, 2020 - 15:36 EST
Monitoring
Monday.com is back up and they are closely monitoring to ensure the problem is fully resolved.
Posted Jan 29, 2020 - 15:10 EST
Identified
Monday.com is working on the issue. Clients with emergencies should contact Polished Geek by phone 919-275-0676 or email. We apologize for the inconvenience and are monitoring the Monday.com updates.
Posted Jan 29, 2020 - 13:41 EST