No worries - Testing our new status page
Incident Report for Polished Geek
Resolved
This incident has been resolved.
Posted Mar 01, 2017 - 20:33 EST
Investigating
Testing our new status page. Nothing to see here.
Posted Mar 01, 2017 - 20:32 EST
This incident affected: PolishedGeek.com Website.