Client billing & support system is down
Incident Report for Polished Geek
Resolved
System is back online and operating normally.
Posted Jun 05, 2018 - 06:38 EDT
Investigating
Polished Geek's client billing & support system is currently offline (timing out). We are investigating the issue with the datacenter now.
Posted Jun 05, 2018 - 05:37 EDT