Billing & Ticket System is down
Incident Report for Polished Geek
Resolved
Billing & support system is back online. Maintenance will be scheduled at a later date to improve stability.
Posted May 16, 2018 - 14:46 EDT
Monitoring
We have applied a secondary fix. The system may remain unstable for a short period of time. We are continuing to monitor it. If you need to reach support urgently in the interim, please call 919-275-0676.
Posted May 16, 2018 - 13:01 EDT
Identified
We are implementing a second fix at this time.
Posted May 16, 2018 - 12:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2018 - 11:11 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 16, 2018 - 10:02 EDT
Investigating
There is an issue with our billing & support ticket system that is currently being investigated. In the meantime, PG clients should use the Intercom chat system to reach us or call 919-275-0676 for any urgent assistance.
Posted May 16, 2018 - 09:29 EDT