Hosting clients may see slow downs
Incident Report for Polished Geek
Resolved
Hosting services are running at full performance. Clients who experience any new problem with response time should open a support ticket and it will be investigated ASAP.
Posted Jun 28, 2018 - 13:58 EDT
Investigating
Our data center is currently experiencing some isolated slow downs and occasional network time outs. We are working to restore full service as quickly as possible.
Posted Jun 28, 2018 - 12:49 EDT