PolishedGeek.com Website outage - temporary DNS issue
Incident Report for Polished Geek
Resolved
All systems functioning normally. Thanks for your patience!
Posted Jun 14, 2018 - 20:04 EDT
Identified
We have identified an issue that is causing temporary interruption in accessing all PolishedGeek.com web addresses. It should be resolved shortly.
Posted Jun 14, 2018 - 19:53 EDT
This incident affected: PolishedGeek.com Website.